$re = '/^(?:[A-Z][a-z]+(?: [A-Z][a-z]+\b(?!-))+(?: [A-Z][a-z]+-[A-Z][a-z]+)?|(?:[A-Z][a-z]+ )?[A-Z][a-z]+-[A-Z][a-z]+)$/m';
$str = 'Apple Banana Couonut-Dates
Apple Banana Test Couonut-Dates
Apple Banana
Banana Couonut-Dates
Couonut-Dates
Apple
Apple Banana Couonut-dates
BanAna couonut-Dates';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);