#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[[0-5][0-9]:[0-5][0-9]]\s*(.+?)\s+-\s+(.+)"
Local $sString = "Text text text" & @CRLF & _
"" & @CRLF & _
"Tracklist:" & @CRLF & _
"[00:00] Sobs - Girl" & @CRLF & _
"[02:25] Mopac - Cross-Eyed Dreaming" & @CRLF & _
"[05:54] L I P S - In Summer" & @CRLF & _
"[09:18] Small Wood House - T.V" & @CRLF & _
"" & @CRLF & _
"Text text text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")