# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[[0-5][0-9]:[0-5][0-9]]\s*(.+?)\s+-\s+(.+)"
test_str = ("Text text text\n\n"
"Tracklist:\n"
"[00:00] Sobs - Girl\n"
"[02:25] Mopac - Cross-Eyed Dreaming\n"
"[05:54] L I P S - In Summer\n"
"[09:18] Small Wood House - T.V\n\n"
"Text text text")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.