package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[0-5][0-9]:[0-5][0-9]]\s*(.+?)\s+-\s+(.+)`)
var str = `Text text text
Tracklist:
[00:00] Sobs - Girl
[02:25] Mopac - Cross-Eyed Dreaming
[05:54] L I P S - In Summer
[09:18] Small Wood House - T.V
Text text text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}