import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[[0-5][0-9]:[0-5][0-9]]\\s*(.+?)\\s+-\\s+(.+)";
final String string = "Text text text\n\n"
+ "Tracklist:\n"
+ "[00:00] Sobs - Girl\n"
+ "[02:25] Mopac - Cross-Eyed Dreaming\n"
+ "[05:54] L I P S - In Summer\n"
+ "[09:18] Small Wood House - T.V\n\n"
+ "Text text text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}