# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\w+,){3}//;t' <<< "a,bn,c,st1,d,kr332,23,b4,46"