package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\w+,){3}`)
var str = []byte(`a,bn,c,st1,d,kr332,23,b4,46`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}