const regex = /(?i)\b[abo]\s+(?:posi|nega)tive\b|\S+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\b[abo]\\s+(?:posi|nega)tive\\b|\\S+', 'gm')
const str = `o negative blood donor in khulna
A Negative donor in sylhet`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}