// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)\b[abo]\s+(?:posi|nega)tive\b|\S+").unwrap();
let string = "o negative blood donor in khulna
A Negative donor in sylhet";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}