re = /(?i)\b[abo]\s+(?:posi|nega)tive\b|\S+/m
str = 'o negative blood donor in khulna
A Negative donor in sylhet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end