$re = '/(?i)\b[abo]\s+(?:posi|nega)tive\b|\S+/m';
$str = 'o negative blood donor in khulna
A Negative donor in sylhet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);