using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\sGWDF](?!.?4)[0-9DTSRF]+";
string substitution = @"";
string input = @"G4 G4 G7 G9 G9 R3 B4 RD2 R3 YD2 R4 R5 RR W BDT Y0 YS G8 WDF
R3 RD2 R3 YD2 R5 RR BDT Y0 YS";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}