import Foundation
let pattern = #"[^\sGWDF](?!.?4)[0-9DTSRF]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
G4 G4 G7 G9 G9 R3 B4 RD2 R3 YD2 R4 R5 RR W BDT Y0 YS G8 WDF
R3 RD2 R3 YD2 R5 RR BDT Y0 YS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)