use strict;
my $str = 'G4 G4 G7 G9 G9 R3 B4 RD2 R3 YD2 R4 R5 RR W BDT Y0 YS G8 WDF
R3 RD2 R3 YD2 R5 RR BDT Y0 YS';
my $regex = qr/[^\sGWDF](?!.?4)[0-9DTSRF]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";