const regex = /(.*).*\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*).*\\1', 'gm')
const str = `100111100111100111100111
11110111101111011110`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);