import re
regex = re.compile(r"(.*).*\1", flags=re.MULTILINE)
test_str = ("100111100111100111100111\n"
"11110111101111011110")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)