$re = '/(.*).*\1/m';
$str = '100111100111100111100111
11110111101111011110';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;