re = /(.*).*\1/m
str = '100111100111100111100111
11110111101111011110'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result