package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^<a.*href="((?:.*)carSale(?:.*))".*>(.*)<\/a>$`)
var str = `<a target="_" href="/carSale/12/..">link1</a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}