const regex = /^<a.*href="((?:.*)carSale(?:.*))".*>(.*)<\/a>$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^<a.*href="((?:.*)carSale(?:.*))".*>(.*)<\\\/a>$', '')
const str = `<a target="_" href="/carSale/12/..">link1</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}