re = /^<a.*href="((?:.*)carSale(?:.*))".*>(.*)<\/a>$/
str = '<a target="_" href="/carSale/12/..">link1</a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end