$re = '/^<a.*href="((?:.*)carSale(?:.*))".*>(.*)<\/a>$/';
$str = '<a target="_" href="/carSale/12/..">link1</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);