#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "612[1-5]00(?:[0-5][0-9]|6[0-4])0000(?:0[0-9]|[1-5][0-9]|6[0-4])00[0-9]{4}"
Local $sString = "61230005000055001234" & @CRLF & _
"12345678900000000000" & @CRLF & _
"hfbfshfjgshfjgsfjhsgf" & @CRLF & _
"fjdhfsjkhfskfhsjfhsfjs" & @CRLF & _
"612332323298983948394838" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")