const regex = /612[1-5]00(?:[0-5][0-9]|6[0-4])0000(?:0[0-9]|[1-5][0-9]|6[0-4])00[0-9]{4}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('612[1-5]00(?:[0-5][0-9]|6[0-4])0000(?:0[0-9]|[1-5][0-9]|6[0-4])00[0-9]{4}', '')
const str = `61230005000055001234
12345678900000000000
hfbfshfjgshfjgsfjhsgf
fjdhfsjkhfskfhsjfhsfjs
612332323298983948394838
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}