import Foundation
let pattern = #"612[1-5]00(?:[0-5][0-9]|6[0-4])0000(?:0[0-9]|[1-5][0-9]|6[0-4])00[0-9]{4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
61230005000055001234
12345678900000000000
hfbfshfjgshfjgsfjhsgf
fjdhfsjkhfskfhsjfhsfjs
612332323298983948394838
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}