$re = '/612[1-5]00(?:[0-5][0-9]|6[0-4])0000(?:0[0-9]|[1-5][0-9]|6[0-4])00[0-9]{4}/';
$str = '61230005000055001234
12345678900000000000
hfbfshfjgshfjgsfjhsgf
fjdhfsjkhfskfhsjfhsfjs
612332323298983948394838
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);