package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?xm)^([^()<>@,;:\\\"/[\]?={}\x01-\x20\x7F]++):[\x20\x09]*+
((?:[\x20\x09]*+[\x21-\x7E\x80-\xFF]++)*+)[\x20\x09]*+[\r]?+\n`)
var str = `foobar: test
hex-string25: wo o pppppp t
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}