import re
regex = re.compile(r"""
^([^()<>@,;:\\\"/[\]?={}\x01-\x20\x7F]++):[\x20\x09]*+
((?:[\x20\x09]*+[\x21-\x7E\x80-\xFF]++)*+)[\x20\x09]*+[\r]?+\n
""", flags=re.VERBOSE | re.MULTILINE)
test_str = ("foobar: test\n"
"hex-string25: wo o pppppp t \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")