const regex = new RegExp('^([^()<>@,;:\\\\\\"/[\\]?={}\\x01-\\x20\\x7F]++):[\\x20\\x09]*+
((?:[\\x20\\x09]*+[\\x21-\\x7E\\x80-\\xFF]++)*+)[\\x20\\x09]*+[\\r]?+\\n', 'gm')
const str = `foobar: test
hex-string25: wo o pppppp t
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}