re = /^([^()<>@,;:\\\"\/[\]?={}\x01-\x20\x7F]++):[\x20\x09]*+
((?:[\x20\x09]*+[\x21-\x7E\x80-\xFF]++)*+)[\x20\x09]*+[\r]?+\n/xm
str = 'foobar: test
hex-string25: wo o pppppp t
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end