const regex = /^Уважаемый клиент, такси ожидает вас. (\b[\S]+\b[\s]*){1,10}. С уважением такси такси.$/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Уважаемый клиент, такси ожидает вас. (\\b[\\S]+\\b[\\s]*){1,10}. С уважением такси такси.$', 'u')
const str = `Уважаемый клиент, такси ожидает вас. Белый Nissan А123ББ. С уважением такси такси.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);