// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)^Уважаемый клиент, такси ожидает вас. (\b[\S]+\b[\s]*){1,10}. С уважением такси такси.$").unwrap();
let string = "Уважаемый клиент, такси ожидает вас. Белый Nissan А123ББ. С уважением такси такси.";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}