$re = '/^Уважаемый клиент, такси ожидает вас. (\b[\S]+\b[\s]*){1,10}. С уважением такси такси.$/u';
$str = 'Уважаемый клиент, такси ожидает вас. Белый Nissan А123ББ. С уважением такси такси.';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;