re = /^Уважаемый клиент, такси ожидает вас. (\b[\S]+\b[\s]*){1,10}. С уважением такси такси.$/
str = 'Уважаемый клиент, такси ожидает вас. Белый Nissan А123ББ. С уважением такси такси.'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result