const regex = /<a(?=[^>]*?rel=nofollow)(?=[^>]*?href="http:\/\/www\.mysite\.com\/.*?")[^>]*?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a(?=[^>]*?rel=nofollow)(?=[^>]*?href="http:\\\/\\\/www\\.mysite\\.com\\\/.*?")[^>]*?>', 'g')
const str = `<a .rel=nofollow .. href="http://www.mysite.com/xyz...." ... >
<a . .. href="huntoffice.ie" ..rel=nofollow. >
<a...> rel=nofollow href="http://www.mysite.com/"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}