$re = '/<a(?=[^>]*?rel=nofollow)(?=[^>]*?href="http:\/\/www\.mysite\.com\/.*?")[^>]*?>/';
$str = '<a .rel=nofollow .. href="http://www.mysite.com/xyz...." ... >
<a . .. href="huntoffice.ie" ..rel=nofollow. >
<a...> rel=nofollow href="http://www.mysite.com/"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);