using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"if \[(.*)\]{(.*)}{(.*)}\s*\/>";
string input = @" 546456 4 356<if [любые символы1]{любые символы2}{любые символы3}/> 546 456 54 6 <if [любые символы1]{любые символы2}{любые символы3}/>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}