package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`if \[(.*)\]{(.*)}{(.*)}\s*\/>`)
var str = ` 546456 4 356<if [любые символы1]{любые символы2}{любые символы3}/> 546 456 54 6 <if [любые символы1]{любые символы2}{любые символы3}/>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}