$re = '~if \[(.*)\]{(.*)}{(.*)}\s*\/>~';
$str = ' 546456 4 356<if [любые символы1]{любые символы2}{любые символы3}/> 546 456 54 6 <if [любые символы1]{любые символы2}{любые симв олы3}/>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);