const regex = new RegExp('if \\[(.*)\\]{(.*)}{(.*)}\\s*\\/>', '')
const str = ` 546456 4 356<if [любые символы1]{любые символы2}{любые символы3}/> 546 456 54 6 <if [любые символы1]{любые с имволы2}{любые символы3}/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}