package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\S+\h+)+\[([A-Za-z0-9]+)\][^()]+\(([^@\s]+@[^@\s.]+\.[^@\s]+)\)$`)
var str = `Some Words [word] (foo@bar.com)
Static Words [word] (foo@bar.com)
RE: Static Words [word] (foo@bar.com)
FW: Static Words [word] (foo@bar.com)
FW: FW: Static Words [word] (foo@bar.com)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}