$re = '/^(?:\S+\h+)+\[([A-Za-z0-9]+)\][^()]+\(([^@\s]+@[^@\s.]+\.[^@\s]+)\)$/m';
$str = 'Some Words [word] (foo@bar.com)
Static Words [word] (foo@bar.com)
RE: Static Words [word] (foo@bar.com)
FW: Static Words [word] (foo@bar.com)
FW: FW: Static Words [word] (foo@bar.com)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);