const regex = /^(?:\S+\h+)+\[([A-Za-z0-9]+)\][^()]+\(([^@\s]+@[^@\s.]+\.[^@\s]+)\)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\S+\\h+)+\\[([A-Za-z0-9]+)\\][^()]+\\(([^@\\s]+@[^@\\s.]+\\.[^@\\s]+)\\)$', 'gm')
const str = `Some Words [word] (foo@bar.com)
Static Words [word] (foo@bar.com)
RE: Static Words [word] (foo@bar.com)
FW: Static Words [word] (foo@bar.com)
FW: FW: Static Words [word] (foo@bar.com)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}