// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\S+\h+)+\[([A-Za-z0-9]+)\][^()]+\(([^@\s]+@[^@\s.]+\.[^@\s]+)\)$").unwrap();
let string = "Some Words [word] (foo@bar.com)
Static Words [word] (foo@bar.com)
RE: Static Words [word] (foo@bar.com)
FW: Static Words [word] (foo@bar.com)
FW: FW: Static Words [word] (foo@bar.com)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}