const regex = new RegExp('\\w+,\\s*f\\s*\\.\\s*\\d\\d-\\s*\\d\\d-\\s*\\d\\d\\d\\d', 'gm')
const str = `Smith, John,
f. 25-12-1990
or only first part of below:
Smith, John, f. 25-12-
1990
Smith, John, f. 25-
12-1990`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}