import re
regex = re.compile(r"\w+,\s*f\s*\.\s*\d\d-\s*\d\d-\s*\d\d\d\d", flags=re.MULTILINE)
test_str = ("Smith, John,\n\n"
"f. 25-12-1990\n\n"
"or only first part of below:\n\n"
"Smith, John, f. 25-12-\n\n"
"1990\n\n"
"Smith, John, f. 25-\n\n"
"12-1990")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")