$re = '/\w+,\s*f\s*\.\s*\d\d-\s*\d\d-\s*\d\d\d\d/m';
$str = 'Smith, John,
f. 25-12-1990
or only first part of below:
Smith, John, f. 25-12-
1990
Smith, John, f. 25-
12-1990';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);