using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z]{3}_(ANEXO|(A|a)nexo)_[A-Za-z]{1,7}_[A-Z]{1}_[A-Z0-9]{2,5}...\.pdf";
string input = @"dge_ANEXO_II_F_TJ[1].pdf
dge_anexo_II_F_TJ[1].pdf
dge_Anexo_II_F_TJ[1].pdf
dge_aNEXO_II_F_TJ[1].pdf
dge_AneXo_II_F_TJ[1].pdf
dGe_AneXo_II_F_TJ[1].pdf // Erro ""G""
dge_AneXo_Ii_j_TJ[1].pdf // Erro ""j""
dge_AneXo_II_F_Tr[1].pdf // Erro ""r""
dge_AneXo_II_F_TJ[TT].pdf // Erro ""TT""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}