import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z]{3}_(ANEXO|(A|a)nexo)_[A-Za-z]{1,7}_[A-Z]{1}_[A-Z0-9]{2,5}...\\.pdf";
final String string = "dge_ANEXO_II_F_TJ[1].pdf\n\n"
+ "dge_anexo_II_F_TJ[1].pdf\n\n"
+ "dge_Anexo_II_F_TJ[1].pdf\n\n"
+ "dge_aNEXO_II_F_TJ[1].pdf\n\n"
+ "dge_AneXo_II_F_TJ[1].pdf\n\n"
+ "dGe_AneXo_II_F_TJ[1].pdf // Erro \"G\"\n\n"
+ "dge_AneXo_Ii_j_TJ[1].pdf // Erro \"j\"\n\n"
+ "dge_AneXo_II_F_Tr[1].pdf // Erro \"r\"\n\n"
+ "dge_AneXo_II_F_TJ[TT].pdf // Erro \"TT\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}