# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-z]{3}_(ANEXO|(A|a)nexo)_[A-Za-z]{1,7}_[A-Z]{1}_[A-Z0-9]{2,5}...\.pdf"
test_str = ("dge_ANEXO_II_F_TJ[1].pdf\n\n"
"dge_anexo_II_F_TJ[1].pdf\n\n"
"dge_Anexo_II_F_TJ[1].pdf\n\n"
"dge_aNEXO_II_F_TJ[1].pdf\n\n"
"dge_AneXo_II_F_TJ[1].pdf\n\n"
"dGe_AneXo_II_F_TJ[1].pdf // Erro \"G\"\n\n"
"dge_AneXo_Ii_j_TJ[1].pdf // Erro \"j\"\n\n"
"dge_AneXo_II_F_Tr[1].pdf // Erro \"r\"\n\n"
"dge_AneXo_II_F_TJ[TT].pdf // Erro \"TT\"\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.